Audio sync drift on Youtube?

Last updated on 9 months ago
Linux Longplays
So I've had this happen to me twice now. Longplay videos uploaded to Youtube seem to go out of sync in the uploading process, to the point that the audio is behind the video by about 3-4 seconds after a few hours of gameplay. The videos in question play fine on my computer and all other devices, and it's the same method each time for each game - so I am fairly certain the method is sound because it only happens SOMETIMES, the problem is with Youtube. For example, in one video I uploaded 1080p and 480p were in sync, but 720p and 360p were OUT of sync. In a recent upload, the entire video was out of sync (or rather, drifted out of sync) in all quality modes. I had to delete the video as it was unwatchable. Very annoyed about this, and have tried searching but to no avail.

Has anyone else has this issue? I'm at a loss for how to address this issue.
ScHlAuChi
This issue is casued by inaccurate muxing.

Muxing programs like MKVMerge etc try to detect the correct framerate automatically, but this sometimes fails and detects the framerate wrong.

So the solution is to manually enter the correct framerate when muxing :)
Linux Longplays
I use Kdenlive to render as MP4 60fps. Why would the video only be out of sync on Youtube? The file appears in sync.

Here's my encoding string:

f=mp4 movflags=+faststart acodec=aac ar=48000 ab=384k vcodec=libx264 progressive=1 preset=fast threads=0 crf=21 g=15 bf=2
Linux Longplays
Ok, I uploaded the video again (10 hour longplay) and it SEEMS to be in sync this time around though it hasn't finished processing all quality modes, so it's definitely a Youtube thing. Pahhh! Maybe it's because I closed the browser window after uploading or perhaps it was interrupted during upload somehow..

This is the second time I've had a longplay video do this.
Linux Longplays
Results are in.

Video is in sync in 1080p and 360p

Video is OUT of sync in 720p, 480p and 240p.

This is very annoying.
You can view all discussion threads in this forum.
You cannot start a new discussion thread in this forum.
You cannot reply in this discussion thread.
You cannot start on a poll in this forum.
You cannot upload attachments in this forum.
You cannot download attachments in this forum.